getting bankid to work on Arch Linux x86_64

thought id share how i got bankid (nexus personal) to work on my Arch64-box.. all credits go to zoledian and his guide on the arch forum. pretty much all you have to do is follow his guide, but since some of the packages are outdated i thought id make a note. ill assume you have yaourt installed in this guide and you really should, nspluginwrapper comes with about a bunch of lib32-dependencies!
First off, install lib32-libidn, lib32-libpng12, nspluginwrapper-debian (the nspluginwrapper aur is outdated and didnt work when i tried to install it) and zip:

yaourt -Sy lib32-libidn lib32-libpng12 nspluginwrapper-debian
pacman -S zip

create the folder /usr/lib/xulrunner-addons/plugins

sudo mkdir -p /usr/lib/xulrunner-addons/plugins

download LinuxPersonal.tgz from https://install.bankid.com/. Unpack and install it:

tar -xvf LinuxPersonal.tgz
cd personal-<your.version>
sudo ./install.<your.version>.sh i

now nspluginwrap it

nspluginwrapper -i /usr/lib/xulrunner-addons/plugins/libplugins.so

and that should be it! you can try it out on https://test.bankid.com/.
I for some reason could not create a new bankid using opera on handelsbanken (it complained about my version) and had to use firefox.. but all the other stuff works just great in both opera and ff.
if you need to troubleshoot it you can do so by adding the following to ~/.personal/config/Personal.cfg

[Diagnostics]
Trace=/directory-you-want-the-log-in

and if it all goes to hell you run

sudo ./install.<your.version>.sh u

to uninstall!

// sluggo

m4s0n501

Comment